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Course Description  
 
This is the second in a series of six workshops about Microsoft Access.  It deals specifically with 
queries, plus some information about filters.  
Many databases contain large varied amounts of information.  There are times when you will need 
to narrow the focus of the information in the database or combine information from multiple tables.  
This is done through the use of queries. Queries allow you to view, change, and analyze data in 
different ways. You can also use them as a source of records for forms and reports.  
The purpose of this session is to familiarize you with some of the different types of queries and 
how they can be used. Our goal is to assist you to learn the software, understand some basic 
concepts and show you some tips and techniques so you can develop your database 
management/programming skills over time.  

The six Access workshops are:  
• Introduction to Access 

• Access Queries  

• Access Reports 

• Access Database Design 

• Access Form Design 

• Access Macros and Advanced Features 
 

Thank you, 
The OIT Technical Support Services Trainers 
West Virginia University 
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What is a Query?  
 
In the strictest sense, a query is a way to answer questions about the data in your tables. It allows 
you to retrieve items in a database that meet a set of criteria that you specify. However, within the 
realm of modern databases, a specialized form of a query can also be used to: 
 

• Define database objects 

• Perform calculations 

• Make new tables 

• Append, delete, or update records 

• Produce data summaries 
 
Access contains some other features that are not strictly classified as queries but they can be 
used to achieve query-like results. These are sorting and filters. Sorting was covered in the 
Introduction to Access workshop. We will discuss filters today before we tackle actual queries. We 
also learned how to use the find command in the Introduction to Access workshop. Wildcards (*, 
?, NULL) will also work for filters and queries. 
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Filters  
A filter can be used to select or exclude a set of records from a table that meets specified criteria. 
 

Types of Filters  

Filter Action Menus Toolbar Shortcut
Menu 

Filter by Selection Uses selected text as criteria X X X 

Filter by Exclusion Uses all text except selected 
text as criteria 

X  X 

Filter By Form Uses sample text entered 
into a blank record as criteria

X X  

Advanced Filter/Sort Uses the Query by Example 
(QBE) grid to set criteria 

X   

 

Limitations of Filters  
While filters are powerful in their search and retrieval capabilities, they do have limitations. 

• Selection limited to one table 

• Cannot calculate new data 

• Must retrieve the entire record 
 
 

Notes on Filters  
• A filter can be saved as a query. You must be in the Advanced Filter/Sort view and then 

choose File > Save as Query from the menus 

• To remove a filter and view all records within a table, select Remove Filter/Sort from the 
toolbar, Records menu, or shortcut menu 

• Multiple fields can be used in a filter, Filter will evaluate from left to right 

• For each specified field in an Advanced Filter, you can indicate either a sort order or criteria 
or both 



Activity 1: Creating and Using Filters  
1. Open the Northwind database 
2. Open the Customers table 
3. Click in any ContactTitle field that has a value of “Owner” 
4. Perform a Filter by Selection: use the button on the toolbar (funnel with lightning bolt), or 

right click and use the shortcut menu, or use the menu under Record > Filter 
5. You should now see ____ records, displaying only those individuals who are owners. 
6. Remove the Filter: click on the funnel button on the toolbar, the shortcut menu, or in the 

menu bar under Record > Filter 
7. Choose Advanced Filter/Sort from the menu bar under Record > Filter 
8. In the lower portion of the screen, 

ContactTitle should be listed in the field 
row. Click in the field textbox of the 
next column 

9. Using the drop down list, choose the 
Country field 

10. Enter “Sales Manager” in the criteria 
area of the ContactTitle field and “USA“ 
in the criteria area of the Country field 
 

11. Click on the Apply Filter button 
12. Choose Advanced Filter/Sort from the 

menu bar under Record > Filter 
13. Remove the criteria from ContactTitle field  
14. Enter “Canada” and “Mexico” in the textboxes below USA in the Country field.  
15. Choose File > Save As Query from the menu (while you are viewing the advanced filter). 
16. Save the query with the name NAFTA 
17. Apply the filter. How many customers are from one of these countries? ____ 
18. Remove the filter 
19. Close the Customers table 
20. Click on the Queries object and open the NAFTA query by double clicking on it. 
21. Switch to Design View (click on the blue triangle in the upper left). 
22. Close the NAFTA query 

 

4 Access Queries  

On your own: 
1. Open any table in the database. 
2. Perform a filter by selection using any technique. When would you want to do this? 
3. Remove the filter. 
4. Perform a filter by exclusion using the Record menu or the shortcut menu. Can you think 

of any reasons why you might want to use this feature? 
5. Remove the filter and close the table. 
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Queries  

Why Use Queries?  
In most cases, the real reason for using a database to store data records is so they can be 
retrieved using some criteria that is specified interactively. Since this is the definition of a query, 
we could logically assume that queries are the main reason for using a database. Access gives 
you a great deal of flexibility and power with queries. You can use them to: 

• Choose fields: You can select the exact fields needed to satisfy the query. You do not 
have to include all of the fields of a record in a query 

• Choose records: You can select records from a table based on a specified criteria 

• Sort records: You can view the results of the query in a specified order 

• Access multiple tables: You can select data from several different tables and place the 
results in a single dynaset. You can even access data from other database management 
systems 

• Perform calculations: You can add new fields in the dynaset that contains the results of 
calculations involving other fields 

• Provide data source: You can use a query as a source of data for forms, reports, and 
other queries 

• Update data: You can update, delete, or append a group of records in one step. You can 
even create a new table that includes some or all of the records from an existing table or 
tables 

 

Using a query  
Microsoft Access contains a number of query wizards or you can create one from scratch using a 
form of Query by Example - where you specify the retrieval criteria by placing typical values in 
columns. You can then treat the columns of sample data as an example for the query. This is the 
exact same concept that we used for the advanced filter earlier.  However, a query is more 
complex than a filter, since it can: 

• Apply to multiple tables 

• Select individual fields instead of full records 

• Be saved and reused 
 



6 Access Queries  

Types of Queries  
Query Type Description 

Select Query A select query is used to view, analyze, or update the 
data in one or more tables. It is the most common type of 
query in Access and it is very similar to the previously 
discussed filter. 

Crosstab Query A crosstab query is used to present the data in rows and 
columns like a spreadsheet. It can summarize large 
amounts of data in an easy-to-read format and it blends 
well with reports and charts. 

Make-Table Query* Creates a new table from the results of a select query.  
It can be used to make table backups, to archive old 
data, or to extract a table of matched data for exporting. 

Update Query* Lets you make global changes to data in one or more 
tables. Allows you to enter one set of changes that could 
be posted to many records with minimal effort. 

Append Query* Allows you to add records to the end of a table. It can be 
used to merge tables together by appending one table to 
the end of another. 

Delete Query* Deletes a group of records from one or more tables. 
Could be used in conjunction with the Make Table query 
to delete archived records from a table after an archive 
table was created and filled. 

Union Query A union query is used to combine the matching fields 
from two or more tables. 

Pass-Through Query A pass-through query is used to send commands to a 
SQL database. 

Data Definition Query A data definition query creates, changes, or deletes 
tables in an Access database using SQL statements. 

 
* These are action queries. When these queries are run design changes are made to the 

database in some manner.  



Creating a Query 

Queries can be created in several different ways. When you click on the New button in the 
Queries object you can choose between the following methods to create a query: 

 

Design View 
• Create a query from scratch. You will get a blank QBE1 grid  

Simple Query Wizard 
• Create a select query from one or more tables for simple selections and calculations 

Crosstab Query 
• Create a crosstab table based on a single table or previously created query 

Find Duplicates Wizard 
• Find duplicate records within a single table or query  

Find Unmatched Wizard 
• Find records in one table that do not match records in a related table 

 
Select the method that you wish to use and click on OK. 
 

                                            
1 QBE: Query By Example – you create a query by selecting fields and specifying criteria instead of typing out SQL 
statements. SQL is "Standard Query Language". 
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Using Design View to Create Queries 

Select a data source 
1. Click on the name of the table or query that 

you wish to use in your query.  
2. Click on Add 
3. Repeat for each table that you want to add 

to the current query 
4. Click on Close when finished 

Alternative technique: you can double click on 
the table names to add them to the query. 

 

Query By Example Window 

 

Query Notes: 
• If more than one table is selected, join lines should be displayed between the tables to 

show the relationships (a primary key in one table is tied to a foreign key in another table). 
You will learn how to establish relationships in the Access Database Design workshop. 

• You can add tables to a query at any time by choosing Show Table from the Query menu 
or clicking on the Show Table button. 

• The type of query that you are creating is displayed in the title bar of the query window. 
You can change this by selecting the desired query type from the Query menu. Most of the 
queries in today's workshop will be Select queries. 

8 Access Queries  
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Selecting Fields 
Only the fields that are added to the QBE grid will be displayed in the resulting dynaset2. Fields 
can be added from multiple tables as long as there is a connection or relationship between the 
two tables. 
 
Fields can be added to the Query in one of three ways: 
1. In the Field row of the QBE grid, click on the drop down menu and choose the field name that 

you want to add. 
2. Click and drag the field that you want to add from the table listing in the top portion of the 

screen to the lower portion. 
3. Double click on the field name that you want to add from the table listings; the field should then 

appear in the right-most column of the QBE grid. 

Use any combinations of these methods to add all of the fields to the query that you wish to 
include. 
 

Query Views  

View Description 

Design View use the QBE grid to create or modify queries 

Datasheet View view to results of the query in a table-like view 

SQL View view or modify the code associated with the query 

PivotTable View view the results of a query as a PivotTable 

PivotChart View view the results of a query as a PivotChart 

Print Preview view the results as they would appear in print 

 Print Preview is only available on the File menu.  
 Design, Datasheet, and SQL views are available using the View button on the toolbar and on 

the View menu.  
 PivotTable and PivotChart views are only available if you created the query using the 

PivotTable wizard. 
 

                                            
2 Dynaset is the official name for the table of results from running a query. 



Activity 2: Create a Simple Query 
1. Click on the Queries object, if it is not already selected. 
2. Click on the New button 
3. Select Design View 
4. Click on OK 
5. Add the Customers table 
6. Click on Close  
7. Add the fields ContactName, ContactTitle, CompanyName, and Country to the QBE grid 
8. Type the word “Owner” in the criteria row below ContactTitle 

 
 

9. Run the query by clicking on the ! button or by switching to Datasheet View 
10. Close the query and save it with the name FindOwners  
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On your own: 
A. 

 Create a simple, single table query on any table in the Northwind database. 
 Select 2 or more fields from the table using your favorite technique. 
 Specify a criteria for at least one of the fields (you might need to preview the data first). 
 Save and close the query. 

B. 
 Open (run) an existing query that comes with the Northwind database. 
 Look at it in Design View. 
 Look at it in SQL View. 
 Close the query. 
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Query Utilities  

Rearranging, Inserting, or Deleting Fields  
While you are selecting the fields to be used in the query, it’s easy to alter the query structure if 
needed. 

Moving a field 
To move a field left or right in the grid, click on the header bar to highlight the field. Then 
click on it again and drag it to a new location. 

Deleting a field 
To delete a field, click on the header bar to highlight the field. Then press the Delete key. 

Inserting a field 
To insert a field, select it from a table field list and drag it to the column position where you 
want it inserted. The other columns will shift to the right to make room for it. 

Specifying Sort Order  
When you view the results of a query, it’s often easier to interpret the data if it is sorted into some 
logical sequence. Sorts can be specified directly in the Query By Example (QBE) grid. 

• Click in the Sort cell for the field that is to be the sort key, pull down the sort options menu, 
and select the desired sort order 

• To sort on multiple fields, arrange them from left to right in the desired sort key order and 
select the desired sort options for each field 

Excluding Fields from the Dynaset  
Fields can be used as part of the selection criteria but excluded from the resulting dynaset. To 
exclude a field from the displayed dynaset, remove the check from the box in the Show cell of the 
QBE grid. 
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Specifying Criteria  
To select certain records from the database tables, we can specify selection criteria that a record 
must meet in order to be selected. The criteria is specified in the form of an expression. 

• A simple expression would be a value. The query would search for all records with that 
value in that field 

• You can use <, >, <=, >=, and <> (not equal to) along with a value. For example, a criteria 
of <200 could be specified for a cost field 

• More complex expressions can be created to search for a range of values or the difference 
between values. The expression builder can be used to create the expression that forms 
the criteria of the query. Start the expression builder and click on the Help button for more 
information on using the builder 

• If you know the syntax of the expression, you can simply type it in the criteria cell 

• Wildcards can be used to specify the criteria. You can use ? in place of any single 
character, * in place of any number of characters, and # in place of any single numeric digit 

 

Combining Selection Criteria  
Selection criteria entered into the Query By Example grid can be combined within columns or 
across columns. The logical operators AND and OR are available for use but are generally implied 
by the position of the criteria within the grid. 

 To use a multiple OR condition within a column, list the first criteria in the cell marked 
Criteria and placed successive items in the cells directly below the first 

 A multiple AND condition within a column is generated by placing both criteria in the same 
cell separated by the keyword AND 

 An AND condition across columns is created by placing the specifications in cells along the 
same criteria row 

 An OR condition across columns is created by placing the specifications in cells in different 
rows 
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Viewing the Resulting Dynaset  
After the criteria specifications are entered in the Query By Example (QBE) grid and the query is 
executed, Access extracts the resulting data from the table and places it in the Dynaset.  
You can view the Dynaset by choosing View > Datasheet from the menu bar or by clicking on the 
Datasheet button on the Toolbar. The dynaset (sometimes referred to as a recordset) resulting 
from a query appears to have all of the characteristics of a table, but it isn’t quite the same.  
It is called a virtual table because it exists in the memory of the computer only. When you exit 
Access, the dynaset is lost unless you take some direct measures to save it. Procedures for 
converting the dynaset to a table are described later in this handout. 
 

Saving the Query  
When you save a query, it becomes part of the database and appears under the Queries entry in 
the Objects list in the Database window.  
Saving a query saves only the structure of the query itself. It does not save the dynaset results 
from running the query. When you open the query in the future, it will re-run the query and display 
a new dynaset result. 

• To save a query, choose the Save command from the File menu while in the Design view. 
If you have not yet saved your query, Access will prompt you to do so when you attempt to 
close the query. 

• Give the query a meaningful name then click the OK button.  
Caution: do not give a query the same name as one of your tables. Also, if you will be 
creating a serious database project, do not use blanks or symbols in your query's name 
(other than numbers and underscores); Visual Basic for Applications modules will be easier 
to create if you have used simpler object names. One naming convention uses the letter "q" 
at the beginning of all query names. 

 

Printing Query Results  
You can print the results of the query by selecting the Datasheet View and choosing the Print 
command from the File menu. The output will be presented in table form with no formatting.  
To produce a nicely formatted report, you will have to create a report. We will discuss that topic in 
the next workshop.  
 



Activity 3: Combining Criteria in a Single Field 
Query will find all products with a price of $25 or greater and less than or equal to $100 
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Products table 
5. Click on Close 
6. Add the fields ProductName and UnitPrice 
7. Enter >25 AND <100 in the criteria area under UnitPrice 
8. Run the query 
9. Switch to Design View 
10. Change the criteria to >= 25 AND <= 100 
11. Run the query – What is the difference between these two criteria? 
12. Close the query and save it with the name Products between $25 and $100 
 

Activity 4: Combining Criteria using Multiple Fields 
Query will find all customers from the USA who are listed as owner or some type of manager in 
the contact title field. 
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Customers table 
5. Click on Close 
6. Add the fields ContactName, ContactTitle, and Country to the grid  
7. Set “USA” as the criteria for Country. Repeat this on the second row 
8. Set the first criteria under ContactTitle as Owner 
9. Set the second row of the 

criteria for ContactTitle as 
*manager 

10. Run the query 
11. Close the query and save it 

with the name USA Owners 
and Managers 
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Activity 5: Creating a Multi-table Sorted Query 
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Customers, Orders,  Order Details, and Products tables 
5. Click Close 
6. Add the fields CompanyName, ProductName, UnitPrice (from Order Details), Quantity, and 

OrderDate 

 
7. In the Sort row, under CompanyName, change it to Ascending 
8. In the Sort row, under OrderDate , change it to Descending 
9. Run the query 
10. Close the query and save it with the name Order Info Sorted by Company  
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On your own: 
1. Create your own query, using one or more tables. 
2. Sort by one or more fields. 
3. Specify a criteria, if you want to. 
4. Run the query. 
5. Save and close the query. 
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Saving Query Results in a Table 
The dynaset that results from a query can be saved by creating a new table to hold the data. This 
is done by creating a Make-Table query. When a Make-Table query is run: 

• Access checks to see if there is an existing table with the name that you have specified. If 
one exists, it will be deleted. If you have not changed the default settings, you will see a 
warning dialog window before this happens. 

• Selects the data according to the criteria. 

• Pastes the data into the new table. If you have not changed the default settings, you will 
see a warning dialog window before this happens. 

 

Activity 6: Make Table Query 
1. Click on New in the query objects  
2. Select Design View 
3. Click on OK 
4. Add the Employees table 
5. Click on Close 
6. Choose any fields to add to the query 
7. Add criteria and sorting, if you want 
8. Run the query to view the results 
9. Switch back to Design View 
10. Choose Make Table from the Query menu 
11. Enter a name for the table (Make sure that the name you enter is different than any object that 

already exists in the database.) 
12. Click on OK 
13. Run the query – running the query is the only way that the table will be created. 
14. Close the query and save it with the name Make Table Test  
15. Notice the different icon that this query has. This is because it is an action query. 
16. Click on the Tables object 
17. Open your table and review the contents – it should appear the same as when you ran the 

query in step 8 
18. Close the table. 
 
Note that this table you created is a static snapshot of the database – if you update or add to the 

original table the query was based on, this snapshot will not change. 
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Calculations 
Within Access you can perform calculations to display results in a field that are not stored in the 
database tables. Expressions are used to within a query to define the desired calculations 

• Calculations can be entered manually or they can be created using the Expression Builder 

• When entering a calculation, you can zoom to expand the input area.  
Press Shift F2 to zoom in on a text box 

• You can change the properties of a calculated field by right clicking on the calculation and 
choosing Properties 

 

Expression Rules 
• When the expression refers to other fields in the QBE grid, their field names must be 

enclosed in square brackets: [field name]. You can label fields and use their labels instead 

• If you want to refer to a field in another table (or if you have a field by the same name in 
another table), then the name must be preceded by the table name, also in brackets, and 
separated by an exclamation point: [table name]![field name] 

• To assign a heading to the column, precede the calculation with a label followed by a colon 
label:[table name]![field name]. If you don’t assign a label to a calculated field, Access 
will assign one of the form (Expr1, Expr2, ...) for you 

• The & operator can be used to concatenate text fields into one field 

• Standard mathematical operations can be used in expressions (+, -, *, /, ^) 
 
 



Activity 7: Performing Calculations  
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Orders, Order Details, and Products tables 
5. Click on Close 
6. Add the fields UnitPrice and Quantity 
7. In the field row of the 3rd column enter the expression  

Total: [Order Details]![UnitPrice]*Quantity 
8. Press Shift F2 to Zoom in, if that will help you see what you're typing. 

9. Add the fields ProductName and ShipCity 
10. Choose Totals from the View menu 
11. In the Totals row, change the entry under the calculated field to Expression 
12. Sort the calculated field Descending  
13. Sort ProductName and ShipCity in ascending order. 
14. Remove the check in the Show row from the UnitPrice and Quantity fields 

 
15. Run the query 
16. Close the query and save it with the name Order Totals 
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Activity 8: Concatenating Names and Calculate Age 
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Employees table 
5. In the field row of the 1st column type: Name: LastName & ", " & FirstName 
6. Add the BirthDate field 
7. In the field row of the 3rd column type: Age: (Now()-BirthDate)/365.25) 

8. Choose Totals from the View menu 
9. In the Totals row, change the entry under the Age calculated field to Expression 
10. Remove the check in the Show row from the BirthDate field 
11. Run the query 
12. Close the query and save it as Employee Age 
 
Note 
To reduce the decimal places in the Age field  
1. Switch back to Design View 
2. Right click in the field row of the Age calculation and choose Properties 
3. Using the drop down menu under Format, choose Fixed 
4. Enter 2 for the number of decimal places 
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Functions Available  
A standard set of calculation functions is available within Access to perform calculations on 
groups of records or to be included in expressions. 

Function Computes  A
ut
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Sum The total of the values in the field X X X X X   

Avg The average of the values in the field X X X X X   

Min The lowest value in the field X X X X X X  

Max The highest value in the field X X X X X X  

Count The number of non-blank values in the field       X

StDev The standard deviation of the values in the field X X X X X   

Var The variance of the values in the field X X X X X   

First The value from the first record       X

Last The value from the last record       X 

 
 
To use these functions: 
1. Create your query as you normally would 
2. Choose Totals from the View menu 
3. For the field that you want to use a function in, 

choose the function from the list in the Total row 
(click in the cell then click on the down triangle). 
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Action Queries 
Action queries are used to change or delete data in a table. This category includes Update, 
Delete, Append, and Make Table queries. Since these actions are very fast and could damage 
your files if they are not constructed correctly, you should always back up your data before using 
them.  
Update queries add a special Update row to the QBE grid. After entering the fields that are to be 
updated in the grid and specifying the selection criteria, the new value is placed in the Update cell. 
If the value in the field matches the criteria, it is replaced with the value in the Update cell. Note 
that the value in the Update cell could be a expression or a calculation.  
Append queries add a special Append To row to the QBE grid. Fields and criteria are entered into 
the grid to select the records from the table that are to be appended to another table. The Append 
To row is used to specify the table that the records are to be appended to. This could be another 
table in this database or it could be in another database. 
The Delete query allows you to specify the fields and criteria that is to be used to select records 
for deletion. A special form of this query allows you to delete records from multiple tables. 
The Make-Table query allows you to create a new table from the results of a query. The fields 
and criteria are used to select records for the new table. Access prompts you for the name of the 
new table. (see page 16) 
A combination of these queries is frequently used to complete a change to a database. A Make-
Table query might be used to create a copy of completed records from a table. A Delete query 
might then be used to remove the records completely from the original table. Finally, an Append 
query might be used to merge the copy of completed records that were deleted from the active 
data into a table that contains other completed records. 



Parameter query  
A parameter query prompts you for the selection criteria when you run the query. To create a 
parameter query: 
1. Create a normal select query but omit the criteria. In place of the criteria, place a parameter 

(generally in the form of a question) inside square brackets. This text will be your meaningful 
prompt to enter information. Repeat this for each field that you want to define as a parameter 

2. Choose Parameters from the Query menu to bring up the Parameter Dialog Box 
3. In the dialog box, enter the first parameter exactly as it is in the criteria cell but without the 

square brackets. The data type of the parameter should match the data type of the field 
4. Repeat for each parameter in the sequence that you want to be prompted for and then click 

OK 

Notes on Parameters 

• If you have more than 1 parameter in a query, you will be prompted for the input in the 
order that the fields are entered into the Query Parameter dialog window 

• You can use a wildcard in your parameter specification. When you enter your parameter 
into the criteria area, add the work like in front of the criteria – Like [Country?] 

Activity 9: Parameter Query 
1. Click on New in the Query objects  
2. Select Design View 
3. Click on OK 
4. Add the Customer table 
5. Click on Close 
6. Add the CompanyName, City, and 

Country fields 
7. In the criteria row under the Country 

field enter [Country?] 
8. Choose Parameters from the Query menu 
9. Type Country? In the first cell of the first row 
10. Leave the data type as Text 
11. Run the query – you will be prompted to supply a country 

name. 
12. Close the query and save it as CompanyByCountry 
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Activity 9b: Another Parameter Query 
1. Repeat Activity 9 but use the Employees table. 
2. For the criteria, specify >[Hired After?]. 
3. Don't forget to modify the Query > Parameters to make 

the data type "Date/Time". 

 
 
 

Query Properties 
 From the Queries Object view (list of queries), change to Details view by clicking on the 

Details button. 
 Right click on the query and choose Properties from the shortcut menu. 
 Enter a meaningful description and click on OK. 
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Crosstab Query 
You can use this type of query to summarize a large table or query dynaset. If you plan to perform 
this query on another query, create the base query first. 

1. Pick a query or table. I created a simple query ahead of time from Products, Customers, 
Orders, and Order Details and chose that. Click on the radio button to see queries instead 
of tables. 

2. Choose a row field. I chose Product. 
3. Choose a column field. I chose country 
4. Choose a data field. I chose OrderDate as the field and Last as the function. 

5. Name the query to save it and choose to view its results. 
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Append Query 
1. Create a duplicate of the Employees Table by creating a simple Make-Tables query. 
2. Edit the duplicate table – delete some records and modify some of the information.  

a. You will have to go to Design view to change the ID number from Autonumber to 
Number (long integer).  

b. Change the ID numbers to numbers higher than 9.  
c. Change the hire date to today’s date using Ctrl ; trick. 
d. Close the new table. 

3. Return to the Queries tab and create a new query based on the small table you created 
above. Double click on the * to include all fields. 

4. Change the query to an append query: Query > Append Query. 
5. Supply Employees as the name of the table to append it to.  
6. Save the query as AddDuplicates. 
7. Run the query by clicking on the ! . Click on Yes to the warning. 
8. Look at your Employees table. You should see additional rows. Close the table. 
9. Now run the Find Duplicates query on your Employees table. 

 

Find Duplicates Query 
1. Start a new query and choose the Find Duplicates Query Wizard. 
2. Select the Employees table. 
3. Choose LastName, FirstName, BirthDate as fields 
4. Choose HireDate and City as additional fields. 
5. Save the query with the name of your choice. 

 
 
 
 
 

6. Choose View Results instead of Modify Design. 
7. Click on the Finish button to view the results. 
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